PARA DAR GRACIAS EN LOS HILOS PASAR POR AQUÍ, EL RESTO SERÁ BORRADO
*

"Lluvia de críticas a Kodi por los cambios en su última versión"

Iniciado Por repollo, El día 19 de Marzo de 2021, 21:02:09 21:02



Autor Tema: Lluvia de críticas a Kodi por los cambios en su última versión  (Leído 88 veces)

0 Usuarios y 1 Visitante están viendo este tema.

  • COLABORADOR
  • ******
  • Panel de agradecimientos
  • -Tu has dado: 1499
  • -Tu has recibido: 68838
  • Mensajes: 6549
  • es
  • Sexo: Masculino
Lluvia de críticas a Kodi por los cambios en su última versión
« en: 19 de Marzo de 2021, 21:02:09 21:02 »
Lluvia de críticas a Kodi por los cambios en su última versión

Estaba claro que iba a pasar. Kodi lleva avisando de ello más de dos años, pero no ha servido de nada. En su versión Kodi 19.0 Matrix, la app deja de ser compatible con addons creados bajo Python 2.0, y sólo funciona con los nuevos creados con Python 3.0. Los usuarios ahora están mostrando su descontento por el cambio.

Kodi ya avisó de que, si querías seguir utilizando un addon basado en Python 2.0, no debías actualizar a la versión 19, y que era conveniente quedarse en la última de Kodi 18 Leia, que es la última que va a ser compatible con los addon antiguos.


Kodi ya no es compatible con Python 2.0

Python 2 fue lanzado en octubre del año 2000, y en 2008, fue anunciado que iba a dejar de tener soporte en el año 2015. Debido a que mucha gente iba a tardar en hacer el cambio, decidieron extender esa fecha al 1 de enero del año 2020. La Fundación Kodi anunció en enero de 2018 que iban a dejar de dar soporte a esta versión en Kodi 19 y posteriores. Kodi 18 era compatible con ambas versiones para ir facilitando la transición, y dando un margen de tres años a los desarrolladores de addons con versiones de prueba disponibles desde noviembre de 2019.

Seguir usando Python 2.0 es muy peligroso en la actualidad, ya que el código y sus librerías ya no tienen soporte y pueden dar lugar a crear apps y addons con vulnerabilidades y otros problemas de seguridad. Por ejemplo, Ubuntu, desde 18.04, ya sólo soporta Python 3, y prácticamente toda la comunidad ha dejado de dar soporte a ello.

El problema es que hay muchos addons antiguos de Kodi que ya no tienen soporte, y por ello no funcionan en la versión más reciente. Hay algunos que tienen más de un lustro encima, y para seguir usándolos la única opción es seguir usando la versión antigua de Kodi. Entre ellos se encuentran muchas skins personalizadas de Kodi que ya no pueden usarse.


Si los addons antiguos no funcionan, no actualices

A pesar de haber publicado varios posts al respecto, mucha gente no se ha enterado del cambio. Por ello, la Fundación Kodi ha emitido una serie de recomendaciones para poder seguir usando la versión antigua. La primera es, básicamente, que no actualices. En Windows, iOS y macOS la actualización no se instala sola.

Si tienes instalada en Windows 10 la versión UWP, sí es posible que se te haya actualizado, donde lo mejor es que instales la versión .exe. Lo mismo ocurre en Android, donde tendrás que tener cuidado e instalar la versión antigua sin borrar los datos de configuración. Esto se puede hacer fácilmente con Titanium Backup si eres root, haciendo copia de seguridad, borrando la app, instalando el APK de la antigua, y restaurar los datos de la app.

En el caso de que quieras usar las versiones más recientes de Kodi, la única opción es que crees y compiles tú mismo el addon o app, o que contactes con los creadores originales de ese addon o skin para que la porten a Python 3. Lo único que piden desde la Fundación Kodi es que los usuarios dejen de culparles a ellos por simplemente migrar a una versión más moderna de Python como ha hecho todo el resto de la industria. También puedes optar por otras opciones como usar alternativas a Kodi.





 

Powered by EzPortal